Truevo Phone Line Issue

Incident Report for Truevo

Resolved

Hello

Please note that the issue we experienced with our phone lines has been resolved. Thank you for your understanding in this matter.

Please feel free to contact us with any questions.

Regards

The Truevo Team
Posted May 23, 2024 - 11:13 CEST

Update

Hello

We are actively working to resolved the issue with our phone lines. Please continue to contact us by emailing us on support@truevo.com.

Thank you for your understanding.

Regards

The Truevo Team
Posted May 23, 2024 - 08:00 CEST

Update

Hello

We are still experiencing the issue with our phone lines. Please continue to contact us by emailing us on support@truevo.com.

Thank you for your understanding.

Regards

The Truevo Team
Posted May 22, 2024 - 14:44 CEST

Identified

Hello

We are currently experiencing an issue with our phone lines and we are working to resolve this matter as soon as possible.

Please contact us by emailing us on support@truevo.com.

We apologise for any inconvenience caused and thank you for your understanding.

Regards

The Truevo Team
Posted May 22, 2024 - 12:08 CEST
This incident affected: Truevo Support Channels (Telephone Support).