Truevo Acquiring Processing Issue

Incident Report for Truevo

Resolved

Our team of engineers have resolved the issue and all services have been successfully restored.

We’re keeping a close eye on the situation. Please accept our sincere apologies for any inconvenience this may have caused.

If you have any questions, please contact us at support@truevo.com.
Posted Apr 11, 2025 - 14:21 CEST

Update

The issue is still ongoing, however, we have identified the cause and are currently implementing a fix.

We will update you accordingly.
Posted Apr 11, 2025 - 13:35 CEST

Update

We are continuing to work on a fix for this issue. Please note that this is affecting only Visa transactions.

We will keep you updated accordingly.
Posted Apr 11, 2025 - 13:00 CEST

Identified

We are experiencing a partial outage on the Truevo platform resulting in an increase in the decline code PS0. Our teams are fully engaged in resolving this matter, and we’ll keep you updated as and when things change.

If you have any questions, please contact us at support@truevo.com.
Posted Apr 11, 2025 - 12:29 CEST
This incident affected: Truevo Unify Acquiring Platform - V1.