Acquiring Platform Processing Issue

Incident Report for Truevo

Resolved

Our team of engineers have resolved the issue and all services have been successfully restored.

We’re keeping a close eye on the situation. Please accept our sincere apologies for any inconvenience this may have caused.

If you have any questions, please contact us at support@truevo.com.
Posted May 03, 2025 - 07:22 CEST

Update

Our teams are still working on resolving the transaction processing issue. We’ll keep you updated as and when things change.
Posted May 03, 2025 - 07:16 CEST

Identified

We’re experiencing a transaction processing issue on the Truevo platform. Our teams are fully engaged in resolving this matter, and we’ll keep you updated as and when things change.

If you have any questions, please contact us at support@truevo.com.
Posted May 03, 2025 - 06:47 CEST
This incident affected: Truevo Acquiring.